Posts by ljaszcza

    Thank you Marcel, one more question:


    the statement: dgate "--imagelister:local|*||dgate --modifypatid:FMI*,%s" > t.bat


    will produce a t.bat file that will change all patid on all images to "FMI*" literally. What I want is the patients ID to be changed to the same number with a FMI in front.
    So 1234 will change to FMI1234. Can you help me rewrite the statement to do that?


    Would this work? Or am I still missing it?

    Code
    1. dgate "--imagelister:local|*||dgate --modifypatid:FMI%id,%s" > t.bat


    update: I tried the above code and it did not work, the t.bat file did not contain the file names...
    I also tried

    Code
    1. dgate "--imagelister:local|*||dgate --modifypatid:FMI%(0010,0020),%s" > t.bat


    That produced a bat file that looks like: dgate --modifypatid:FMI(0010,0020),F:the file name.
    I tried it just to see and it produces 100% **File to modify does not exist or is not on a MAG device error.


    Ok, I'm open to suggestions, I'm still not sure how to structure this command.

    Oops, it just finished!
    Patient.txt now has the image files. Hmm, it has both local and mirror drive files. That's why it was so slow, it was going through the whole offsite backup network drive too. Shouldn't the "local" setting limit it to MAG0?

    Still having hard time. Here is what is happening:
    I open command window.
    I change to d:\conquest1 (my conquest directory)
    I execute dgate "--imagelister:local|*||%s|patient.txt"; I want every patient to be listed in patient.txt
    The system runs for about a minute, patient.txt is created in the directory.
    When I get the command prompt back, patient.txt is empty.
    If I try to delete patient.txt I can't, it says it's being used...
    I've waited about 10 minutes now, no change.Patient.txt is locked and empty. The number of patients in this conquest instance is not great, maybe 100 patients. This is conquest v.14, native mySQL. No messages show up in pacstrouble.log

    I'm still struggling with this issue. I still want to change many patient files from patid=xxxx to patid=FMIxxxx with as little input as possible.


    It seems I can't use wild cards so "dgate --modifypatid:*,FMI*" does not work.


    I tried a batch file idea from a different thread:
    dgate "--imagelister:local|OLDPATID||dgate --modifypatid:NEWPATID,%s" > t.bat
    but t.bat remains empty when I run this. I have replaced OLDPATID with the ID of my test patient, and the NEWPATID with my new id.


    I tried command line dgate "--imagelister:local|patid||%s"
    There is no output.


    Right now I am working in a test directory, a few patient files, dgate.exe, dgate.dic and dicom.ini.


    I am not understanding something. I think maybe dgate is not looking in the right place (my test directory). Any ideas? Help?

    We have picked up some new clinics and have a problem with overlapping patient IDs. So I need to change the ID for one of the clinics. Basically this amounts to taking all the patients in a directory and changing the patient IDs from #### to FMI####. So, for every image, the patient ID would change from say "1234" to "FMI1234". Does anyone know of a tool that could do this? We are talking about housands of patients, well over a million images.So an automated process is needed.
    I think a simple batch file using dgate --modifypatid * FMI* would work... Anyone have comments?

    I'm looking at the process right now. Memory usage is 25k, that seems about right. I/O usage is stable (no images coming in). CPU is 50% (on a quad machine...). I see 13 threads, 2 are consuming 25% CPU each. Both have a start address of 0x1ad2. Hmm, I see 4 TCP ports open, two labeled "CLOSE_WAIT", this does seem like a improper connection termination.


    My dicom ini is:


    # This file contains configuration information for the DICOM server
    # Do not edit unless you know what you are doing


    [sscscp]
    MicroPACS = sscscp
    Edition = Personal


    # Network configuration: server name and TCP/IP port#
    MyACRNema = FAIRLIGHT1
    TCPPort = 5680


    # Reference to other files: known dicom servers; database layout; sops
    ACRNemaMap = acrnema.map
    kFactorFile = dicom.sql
    SOPClassList = dgatesop.lst


    # Host, database, username and password for MySql database
    SQLHost = localhost
    SQLServer = conquest
    Username = root
    Password = orion
    MySql = 1
    DoubleBackSlashToDB = 1


    # Configure database
    TruncateFieldNames = 10
    MaxFieldLength = 254
    MaxFileNameLength = 255
    FixPhilips = 0
    FixKodak = 0
    KeepAlive = 60
    LargeFileSizeKB = 1024
    ZipTime = 05:
    UIDPrefix = 1.2.826.0.1.3680043.2.135.733151.17777964
    EnableReadAheadThread = 1
    PatientQuerySortOrder =
    StudyQuerySortOrder =
    SeriesQuerySortOrder =
    ImageQuerySortOrder =
    IndexDBF = 1
    PackDBF = 0
    LongQueryDBF = 1000
    TCPIPTimeOut = 300
    FailHoldOff = 60
    RetryDelay = 100
    QueueSize = 128
    WorkListMode = 0
    DebugLevel = 0
    Prefetcher = 0
    LRUSort =
    AllowTruncate =
    DecompressNon16BitsJpeg = 1
    UseBuiltInDecompressor = 1
    IgnoreOutOfMemoryErrors = 0
    PadAEWithZeros = 0
    FileNameSyntax = 4


    # Configuration of compression for incoming images and archival
    DroppedFileCompression = uj
    IncomingCompression = uj
    ArchiveCompression = as


    # Names of the database tables
    PatientTableName = DICOMPatients
    StudyTableName = DICOMStudies
    SeriesTableName = DICOMSeries
    ImageTableName = DICOMImages
    DMarkTableName = DICOMAccessUpdates
    RegisteredMOPDeviceTable = RegisteredMOPIDs
    UIDToMOPIDTable = UIDToMOPID
    UIDToCDRIDTable = UIDToCDRID


    # Banner and host for debug information
    PACSName = FAIRLIGHT1
    OperatorConsole = 127.0.0.1


    # Configure email of error messages
    MailHost =
    MailSignon =
    MailFromName =
    MailRcptName1 =
    MailCollectTime = 1
    MailWaitTime = 10


    # Configuration of disk(s) to store images
    MAGDeviceThreshhold = 0
    MAGDevices = 1
    MAGDevice0 = F:\DICOM\DICOMND\
    NightlyCleanThreshhold = 0


    # Configuration of mirror disk(s)
    MIRRORDevices = 1
    MIRRORDevice0 = \\n5200\usbhdd\fairdicom\NorthDakota\


    # Configuration of forwarding and/or converter programs to export DICOM slices
    ForwardAssociationLevel = IMAGE
    ForwardAssociationCloseDelay = 5
    ForwardAssociationRefreshDelay = 3600
    ForwardAssociationRelease = 0


    ExportConverters = 6
    ExportConverter0 = forward patient age -1000+0 modality CR to FAIRLIGHT5
    ExportConverter1 = forward to FAIRLIGHT5
    ExportConverter2 = forward patient age -1000+0 modality CR to FAIRLIGHT6
    ExportConverter3 = forward patient age -400+0 modality MG to FAIRLIGHT6
    ExportConverter4 = forward to FAIRLIGHT6
    ExportConverter5 = between "17", "06"; forward to risviewjh


    ForwardCollectDelay = 300
    MaximumExportRetries = 0
    MaximumDelayedFetchForwardRetries = 0



    ignoreoutofmemoryerrors = 1
    ForwardAssociationRelease = 1

    Hi, I'm running into a problem which is sporadic but seems to have started with conquest v14 although I changed from MySQL to WAMP based MySQL at the same time. I am running on server 2003, native SQL client, MySQL v5.x(WAMP 2.0).
    I have observed a problem in that I run taskmanager and find that one of the dgate.exe processes is utilizing 100% of a cpu (It's a quad core machine so 25% total). This persists even with no dicom activity. I have 4 instances of Conquest running on different ports so with time, all 4 of the instances will convert to high CPU and I get 100% CPU utilization. The machine then gets very slow and drops images.
    Terminating the offending Dgate.exe process or rebooting solves the problem. Sometimes I don't see the high CPU utilization problem for days, other times it happens in hours after reboot.
    I don't see anything in particular with the logs. The offending dgate.exe process continues to function without problems until all 4 hit 100% then the machine really slows and starts to fail.
    Anyone have a similar experience?

    Well, my ***multiplex: connection terminated error went away "on it's own". IT staff at the clinic denies making changes, the mobile MR guys deny making changes but the problem went away. I suppose that in my case it was some hardware issue that IT created but didn't want to admit to or dismissed as trivial. Or perhaps a Windows patch, the machine is XP SP2 set to download MS updates automatically...
    Whatever the case, I'm glad it's gone, I wish I knew what the heck happened though.

    Well, this problem just popped up for me, conquest talking to a mobile GE MRI. The system worked one week and failed with the multiplex error the next week. The mobile unit staff denies any changes to their setup. This install of conquest is actually minimal, only one export filter. Debug log really has nothing in it of use. Sigh. I'll write back if I get any ideas.

    I'm having an issue installing a Howtek 460 scanner with twain. When I try to acquire an image with kpacs 1.6 I get an error that Howtek32.src is corrupt or removed. Is this a file that Kpacs creates or uses? If so, where should it be located?
    Thanks,
    LJJ

    I am getting images from a Emajon PACS unit. The mammo films almost always fail. The error message is (debug 4)


    [FLTSIDNEY] 0000,0002 28 UI AffectedSOPClassUID "1.2.840.10008.5.1.4.1.1.1.2"
    [FLTSIDNEY] 0000,0100 2 US CommandField 1
    [FLTSIDNEY] 0000,0110 2 US MessageID 0
    [FLTSIDNEY] 0000,0700 2 US Priority 0
    [FLTSIDNEY] 0000,0800 2 US DataSetType 258
    [FLTSIDNEY] 0000,1000 54 UI AffectedSOPInstanceU "1.2.392.200036.9125.4.0.135221179.879958528.3701491744"
    [FLTSIDNEY] Failed STORAGE
    [FLTSIDNEY] ***Client Error: Unknown Command: 0001**
    [FLTSIDNEY] ***Connection Terminated


    I think this may be a Emajon problem but it is somewhat sporadic, occasionally an image goes through. Does this error message give me any useful information or is it just a nonspecific failure? The mammo films are coming over a T1 line and the sending pacs is not specified in the conquest known DICOM provider list. I get a number of CTs, MRIs, CR images from the same source without a problem.
    Conquest is v14, 32bit, native mySql, no other problems really. I get digital mammos from several other sources, some slower than the T1...


    Any ideas anyone?

    Marcel,
    I am just starting to use the webserver and cannot display images either, the button to display is not there. Here is a sample page source...


    <HEAD><TITLE>Conquest DICOM server - version 1.4.14</TITLE></HEAD>
    <BODY BGCOLOR='CFDFCF'>
    <H2>Conquest DICOM server - version 1.4.14</H2>
    <table RULES=ALL BORDER=1>
    <Caption>List of selected series on FAIRLIGHT1</caption>
    <TR><TD>Date<TD>Time<TD>Modality<TD>Name<TD>ID<TD>UID</TR>
    <TR><TD>20081007<TD><TD>CR<TD>xxx xxx<TD>CB16094<TD>1.22.333.4444.55555.20081007095132.1.1</TR><TD><A HREF=dgate.exe?port=5680&address=127.0.0.1&mode=seriesmover&series=CB16094:1.22.333.4444.55555.20081007095132.1.1&source=FAIRLIGHT1>push</A>
    </table>
    </BODY>

    I'll second the usage of MySql. My latest iteration is stable and maintenance free for a little over three years. I like the maintenance free part. Also, I use redundant power supplies and UPS backup. Our utility provides somewhat unstable power.